Suche:

FAQ-Bereich



Folgende häufig gestellte Fragen und Antworten haben wir für Sie zusammengefasst.

Rubrik: WEBSERVER

  1. Daten können nicht geladen werden


Daten können nicht geladen werden

Von Kunden erreichte uns eine Meldung, das es Schwierigkeiten gibt Dateien auf den Webserver zu laden. Da wir kurz vorher den Webserver geupdatet haben konnte es nur an dessen Konfiguration liegen. Also erst mal die error Datei des Kunden ausgewertet und den Fehler lokalisiert. (mod_fcgid: HTTP request length 139264 (so far) exceeds MaxRequestLen (131072))

Hier nun folgendes zu gefunden: Die Fehlermeldung kann nach einem Update von Debian Lenny auf Debian Squeeze aufgrund der Standardeinstellungen des Apache-fastCGI-Moduls ausgegeben werden. Selbst wenn in der php Konfiguration deutlich größere Dateien erlaubt werden, werden Uploads ab einer Größe von 130Kb nicht mehr verarbeitet. Stattdessen meldet der Webserver, dass die maximal erlaubte Größe überschritten wurde.

Dieses Problem wird dadurch hervorgerufen, dass unter Debian Lenny standardmäßig ist eine maximale Request Länge von 1GB eingestellt ist. In den Standardeinstellungen von Squeeze sind es allerdings nur noch 130Kb.

Hier nun die Lösung:
Um das Problem zu beheben muss in den Einstellungen des Webservers die maximale Größe des Requests angehoben werden. Hierzu ändern wir den Inhalt der Datei /etc/apache2/mods-available/fcgid.conf auf den gewünschten Wert mit folgendem Codeschnipsel: FcgidMaxRequestLen 5242880


« Zurück

Software: boTickets 2.5.1 © 2006-2018 www.Bo)Combo.de